Backdrop CMS does not sufficiently sanitize field labels before they are displayed in certain places
CVE-2024-41709GHSA-3wmx-48g3-x66g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (backdrop/backdrop 1.28.2, 1.27.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist backdrop/backdrop
- Affected
- < 1.27.3>= 1.28.0, < 1.28.2
- Fixed in
- 1.27.3, 1.28.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3wmx-48g3-x66g lists affected ranges: Packagist backdrop/backdrop >=0 =1.28.0 <1.28.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-41709: 0.32% estimated exploitation activity in the next 30 days; percentile 24.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Backdrop CMS before 1.27.3 and 1.28.x before 1.28.2 does not sufficiently sanitize field labels before they are displayed in certain places. This vulnerability is mitigated by the fact that an attacker must have a role with the "administer fields" permission.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3wmx-48g3-x66g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41709 Advisory: Backdrop CMS does not sufficiently sanitize field labels before they are displayed in certain places IDs: CVE-2024-41709, GHSA-3wmx-48g3-x66g Record: https://patchnext.com/advisories/cve-2024-41709 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: backdrop/backdrop 1.28.2, 1.27.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist backdrop/backdrop: affected < 1.27.3; >= 1.28.0, < 1.28.2; fixed in 1.27.3, 1.28.2 ## Suggested inspection (read-only) - Packagist backdrop/backdrop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on backdrop/backdrop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3wmx-48g3-x66g (GitHub-reviewed advisory GHSA-3wmx-48g3-x66g lists affected ranges: Packagist backdrop/backdrop >=0 =1.28.0 <1.28.2) Commands are suggestions: review each one before running it.
Loading voting…