Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs
CVE-2024-41676GHSA-5vrp-638w-p8m2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- < 20.10.1
- Fixed in
- 20.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vrp-638w-p8m2 lists affected ranges: Packagist openmage/magento-lts >=0 <20.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2024-41676: 0.36% estimated exploitation activity in the next 30 days; percentile 29.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This XSS vulnerability is about the system configs design/header/welcome design/header/logosrc design/header/logosrcsmall design/header/logoalt They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases. But because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. While this is in most usage scenarios not a relevant issue, some people work with more restrictive roles in the backend. Here the ability to inject JavaScript with these settings would be an unintended and unwanted privilege. Patches Has the problem been patched? What versions should users upgrade to? The problem is patched with Version 20.10.1 or higher. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Possible mitigations are Restricting access to the System Configs checking templates where these settings are used to apply proper html filtering For…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5vrp-638w-p8m2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41676 Advisory: Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs IDs: CVE-2024-41676, GHSA-5vrp-638w-p8m2 Record: https://patchnext.com/advisories/cve-2024-41676 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected < 20.10.1; fixed in 20.10.1 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5vrp-638w-p8m2 (GitHub-reviewed advisory GHSA-5vrp-638w-p8m2 lists affected ranges: Packagist openmage/magento-lts >=0 <20.10.1) Commands are suggestions: review each one before running it.
Loading voting…