Skip to content

← Actionable
High, CVSS 7.1amended

Sentry vulnerable to stored Cross-Site Scripting (XSS)

CVE-2024-41656GHSA-fm88-hc3v-3www

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 24.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sentry

    Affected
    >= 10.0.0, < 24.7.1
    Fixed in
    24.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-41656: 0.47% estimated exploitation activity in the next 30 days; percentile 40.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unsanitized payload sent by an Integration platform integration allows the storage of arbitrary HTML tags on the Sentry side. This payload could subsequently be rendered on the Issues page, creating a Stored Cross-Site Scripting (XSS) vulnerability. This vulnerability might lead to the execution of arbitrary scripts in the context of a user’s browser. Self-hosted Sentry users may be impacted if untrustworthy Integration platform integrations send external issues to their Sentry instance. Patches The patch has been released in Sentry 24.7.1 Workarounds For Sentry SaaS customers, no action is needed. This has been patched on July 22, and even prior to the fix, the exploitation was not possible due to the strict Content Security Policy deployed on sentry.io site. For self-hosted users, we strongly recommend upgrading Sentry to the latest version. If it is not possible, you could enable CSP on your self-hosted installation with CSPREPORTONLY = False (enforcing mode). This will…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fm88-hc3v-3www

  2. Revision 1 · created ·

    Published from osv record GHSA-fm88-hc3v-3www

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41656

Advisory: Sentry vulnerable to stored Cross-Site Scripting (XSS)
IDs: CVE-2024-41656, GHSA-fm88-hc3v-3www
Record: https://patchnext.com/advisories/cve-2024-41656 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sentry 24.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sentry: affected >= 10.0.0, < 24.7.1; fixed in 24.7.1

## Suggested inspection (read-only)
- `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sentry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fm88-hc3v-3www (OSV record GHSA-fm88-hc3v-3www lists affected ranges: PyPI sentry >=10.0.0 <24.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fm88-hc3v-3www (GitHub-reviewed advisory GHSA-fm88-hc3v-3www lists affected ranges: PyPI sentry >=10.0.0 <24.7.1)

Commands are suggestions: review each one before running it.

Loading voting…