Skip to content

← Actionable
Low, CVSS 2.6amended

Firebase vulnerable to CRSF attack

CVE-2024-4128GHSA-rcm2-22f3-pqv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (firebase-tools 13.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-4128: 0.13% estimated exploitation activity in the next 30 days; percentile 2.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This vulnerability was a potential CSRF attack. When running the Firebase emulator suite, there is an export endpoint that is used normally to export data from running emulators. If a user was running the emulator and navigated to a malicious website with the exploit on a browser that allowed calls to localhost (ie Chrome before v94), the website could exfiltrate emulator data. We recommend upgrading past version 13.6.0 or commit 068a2b08dc308c7ab4b569617f5fc8821237e3a0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rcm2-22f3-pqv3

  2. Revision 1 · created ·

    Published from osv record GHSA-rcm2-22f3-pqv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-4128

Advisory: Firebase vulnerable to CRSF attack
IDs: CVE-2024-4128, GHSA-rcm2-22f3-pqv3
Record: https://patchnext.com/advisories/cve-2024-4128 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: firebase-tools 13.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm firebase-tools: affected < 13.6.0; fixed in 13.6.0

## Suggested inspection (read-only)
- `npm ls firebase-tools --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on firebase-tools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rcm2-22f3-pqv3 (OSV record GHSA-rcm2-22f3-pqv3 lists affected ranges: npm firebase-tools >=0 <13.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rcm2-22f3-pqv3 (GitHub-reviewed advisory GHSA-rcm2-22f3-pqv3 lists affected ranges: npm firebase-tools >=0 <13.6.0)

Commands are suggestions: review each one before running it.

Loading voting…