Skip to content

← Actionable
Medium, CVSS 6.9amended

ops leaking secrets if subprocess.CalledProcessError happens with a secret-* CLI command

CVE-2024-41129GHSA-hcmv-jmqh-fjgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ops 2.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ops

    Affected
    >= 2.0.0, < 2.15.0
    Fixed in
    2.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-41129: 0.20% estimated exploitation activity in the next 30 days; percentile 9.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The issue here is that we pass the secret content as one of the args via CLI. This issue may affect any of our charms that are using: Juju (=3.0), Juju secrets and not correctly capturing and processing subprocess.CalledProcessError. There are two points that may log this command, in different files: First, if there is an error during a secret handling, there will be a subprocess.CalledProcessError, which will contain the CLI comand + all its args. This is going to be logged in any logging level. This exception, if not caught by the charm, will bubble up to the /var/log/juju/ logs and syslog journal. Now, on Ubuntu 22.04, these logs are protected with: Second, certain audit setups may log terminal commands, which would result in this command being logged with its secrets. It is unknown if this is done on ubuntu security benchmarks, such as CIS hardening. Keep in mind these logs may be copied or even backed up. Which exposes it to more services in the user's environment (e.g.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hcmv-jmqh-fjgm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hcmv-jmqh-fjgm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41129

Advisory: ops leaking secrets if `subprocess.CalledProcessError` happens with a `secret-*` CLI command
IDs: CVE-2024-41129, GHSA-hcmv-jmqh-fjgm
Record: https://patchnext.com/advisories/cve-2024-41129 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ops 2.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ops: affected >= 2.0.0, < 2.15.0; fixed in 2.15.0

## Suggested inspection (read-only)
- `python -m pip show ops`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ops.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hcmv-jmqh-fjgm (OSV record GHSA-hcmv-jmqh-fjgm lists affected ranges: PyPI ops >=2.0.0 <2.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hcmv-jmqh-fjgm (GitHub-reviewed advisory GHSA-hcmv-jmqh-fjgm lists affected ranges: PyPI ops >=2.0.0 <2.15.0)

Commands are suggestions: review each one before running it.

Loading voting…