Skip to content

← Actionable
High, CVSS 8.7

Woodpecker's custom workspace allow to overwrite plugin entrypoint executable

CVE-2024-41121GHSA-xw35-rrcp-g7xm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.woodpecker-ci.org/woodpecker/v2 2.7.0; go.woodpecker-ci.org/woodpecker 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-41121: 0.74% estimated exploitation activity in the next 30 days; percentile 54.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The server allow to create any user who can trigger a pipeline run malicious workflows: - Those workflows can either lead to a host takeover that runs the agent executing the workflow. - Or allow to extract the secrets who would be normally provided to the plugins who's entrypoint are overwritten. Patches https://github.com/woodpecker-ci/woodpecker/pull/3933 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Enable the "gated" repo feature and review each change upfront References - https://github.com/woodpecker-ci/woodpecker/pull/3933 - https://github.com/woodpecker-ci/woodpecker-security/pull/11 - https://github.com/woodpecker-ci/woodpecker-security/issues/8 (info will be published later at https://github.com/woodpecker-ci/woodpecker/issues/3924) - https://github.com/woodpecker-ci/woodpecker-security/issues/9 (info will be published later at https://github.com/woodpecker-ci/woodpecker/issues/3924) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xw35-rrcp-g7xm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41121

Advisory: Woodpecker's custom workspace allow to overwrite plugin entrypoint executable
IDs: CVE-2024-41121, GHSA-xw35-rrcp-g7xm
Record: https://patchnext.com/advisories/cve-2024-41121 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.woodpecker-ci.org/woodpecker/v2 2.7.0; go.woodpecker-ci.org/woodpecker 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.woodpecker-ci.org/woodpecker/v2: affected < 2.7.0; fixed in 2.7.0
- Go go.woodpecker-ci.org/woodpecker: affected < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- Go go.woodpecker-ci.org/woodpecker/v2: check the installed version with your package manager.
- Go go.woodpecker-ci.org/woodpecker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.woodpecker-ci.org/woodpecker/v2, go.woodpecker-ci.org/woodpecker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xw35-rrcp-g7xm (GitHub-reviewed advisory GHSA-xw35-rrcp-g7xm lists affected ranges: Go go.woodpecker-ci.org/woodpecker/v2 >=0 =0 <2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…