Skip to content

← Actionable
High, CVSS 8.9amended

LoLLMS Command Injection vulnerability

CVE-2024-4078GHSA-pwc9-q4hj-pg8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lollms 9.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lollms

    Affected
    < 9.5.0
    Fixed in
    9.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-4078: 0.92% estimated exploitation activity in the next 30 days; percentile 60.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in the parisneo/lollms, specifically in the /unInstallbinding endpoint, allows for arbitrary code execution due to insufficient sanitization of user input. The issue arises from the lack of path sanitization when handling the name parameter in the unInstallbinding function, allowing an attacker to traverse directories and execute arbitrary code by loading a malicious init.py file. This vulnerability affects the latest version of the software. The exploitation of this vulnerability could lead to remote code execution on the system where parisneo/lollms is deployed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pwc9-q4hj-pg8g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pwc9-q4hj-pg8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-4078

Advisory: LoLLMS Command Injection vulnerability
IDs: CVE-2024-4078, GHSA-pwc9-q4hj-pg8g
Record: https://patchnext.com/advisories/cve-2024-4078 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lollms 9.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lollms: affected < 9.5.0; fixed in 9.5.0

## Suggested inspection (read-only)
- `python -m pip show lollms`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lollms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pwc9-q4hj-pg8g (OSV record GHSA-pwc9-q4hj-pg8g lists affected ranges: PyPI lollms >=0 <9.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pwc9-q4hj-pg8g (GitHub-reviewed advisory GHSA-pwc9-q4hj-pg8g lists affected ranges: PyPI lollms >=0 <9.5.0)

Commands are suggestions: review each one before running it.

Loading voting…