Sentry's Python SDK unintentionally exposes environment variables to subprocesses
CVE-2024-40647GHSA-g92j-qhmh-64v2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry-sdk 2.8.0, 1.45.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry-sdk
- Affected
- >= 2.0.0a1, < 2.8.0< 1.45.1
- Fixed in
- 2.8.0, 1.45.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g92j-qhmh-64v2 lists affected ranges: PyPI sentry-sdk >=2.0.0a1 =0 <1.45.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g92j-qhmh-64v2 lists affected ranges: PyPI sentry-sdk >=2.0.0a1 =0 <1.45.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2024-40647: 0.20% estimated exploitation activity in the next 30 days; percentile 9.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The bug in Sentry's Python SDK <2.8.0 results in the unintentional exposure of environment variables to subprocesses despite the env={} setting. Details In Python's subprocess calls, all environment variables are passed to subprocesses by default. However, if you specifically do not want them to be passed to subprocesses, you may use env argument in subprocess calls, like in this example: If you'd want to not pass any variables, you can set an empty dict: However, the bug in Sentry SDK <2.8.0 causes all environment variables to be passed to the subprocesses when env={} is set, unless the Sentry SDK's Stdlib integration is disabled. The Stdlib integration is enabled by default. Patches The issue has been patched in https://github.com/getsentry/sentry-python/pull/3251 and the fix released in sentry-sdk==2.8.0. The fix was also backported to sentry-sdk==1.45.1. Workarounds We strongly recommend upgrading to the latest SDK version. However, if it's not possible, and if passing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g92j-qhmh-64v2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g92j-qhmh-64v2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-40647 Advisory: Sentry's Python SDK unintentionally exposes environment variables to subprocesses IDs: CVE-2024-40647, GHSA-g92j-qhmh-64v2 Record: https://patchnext.com/advisories/cve-2024-40647 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry-sdk 2.8.0, 1.45.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry-sdk: affected >= 2.0.0a1, < 2.8.0; < 1.45.1; fixed in 2.8.0, 1.45.1 ## Suggested inspection (read-only) - `python -m pip show sentry-sdk`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g92j-qhmh-64v2 (OSV record GHSA-g92j-qhmh-64v2 lists affected ranges: PyPI sentry-sdk >=2.0.0a1 =0 <1.45.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g92j-qhmh-64v2 (GitHub-reviewed advisory GHSA-g92j-qhmh-64v2 lists affected ranges: PyPI sentry-sdk >=2.0.0a1 =0 <1.45.1) Commands are suggestions: review each one before running it.
Loading voting…