dbt has an implicit override for built-in materializations from installed packages
CVE-2024-40637GHSA-p3f3-5ccg-83xq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-core 1.7.14, 1.6.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dbt-core
- Affected
- >= 1.6.0, < 1.6.14>= 1.7.0, < 1.7.14
- Fixed in
- 1.7.14, 1.6.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p3f3-5ccg-83xq lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p3f3-5ccg-83xq lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-40637: 0.37% estimated exploitation activity in the next 30 days; percentile 31.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. Patches Has the problem been patched? What versions should users upgrade to? Fixed on 1.8.0, and patched for 1.6.14 and 1.7.14 releases. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Previously, a materialization defined in a package that shared a name with one of the built-in materializations would be preferred by default, without user action which is surprising and makes it more difficult to detect the insecure behaviour. We've changed the default behaviour to require explicit overrides by users in 1.8.0, and provided the ability to opt-out of built-in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p3f3-5ccg-83xq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p3f3-5ccg-83xq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-40637 Advisory: dbt has an implicit override for built-in materializations from installed packages IDs: CVE-2024-40637, GHSA-p3f3-5ccg-83xq Record: https://patchnext.com/advisories/cve-2024-40637 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dbt-core 1.7.14, 1.6.14. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dbt-core: affected >= 1.6.0, < 1.6.14; >= 1.7.0, < 1.7.14; fixed in 1.7.14, 1.6.14 ## Suggested inspection (read-only) - `python -m pip show dbt-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dbt-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p3f3-5ccg-83xq (OSV record GHSA-p3f3-5ccg-83xq lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.14 (fixed)) - Verified: https://github.com/advisories/GHSA-p3f3-5ccg-83xq (GitHub-reviewed advisory GHSA-p3f3-5ccg-83xq lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.14) Commands are suggestions: review each one before running it.
Loading voting…