Skip to content

← Actionable
High, CVSS 8.7

Sylius has a security vulnerability via adjustments API endpoint

CVE-2024-40633GHSA-55rf-8q29-4g43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.13.4, 1.12.19, 1.11.17, 1.10.16, 1.9.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    >= 1.13.0-alpha.1, < 1.13.4>= 1.12.0-alpha.1, < 1.12.19< 1.9.12>= 1.10.0-alpha.1, <= 1.10.15>= 1.11.0-alpha.1, <= 1.11.16
    Fixed in
    1.10.16, 1.11.17, 1.13.4, 1.9.12, 1.12.19

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-55rf-8q29-4g43 lists affected ranges: Packagist sylius/sylius >=1.13.0-alpha.1 =1.12.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <=1.11.16

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-40633: 0.38% estimated exploitation activity in the next 30 days; percentile 32.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A security vulnerability was discovered in the /api/v2/shop/adjustments/{id} endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. Patches The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.19, 1.13.4 and above. The /api/v2/shop/adjustments/{id} will always return 404 status. Workarounds Using YAML configuration: Create config/apiplatform/Adjustment.yaml file: Or using XML configuration: Note: This is the only way of disabling the vulnerable endpoint for Sylius 1.9, as YAML configuration is not supported in that version. Copy the original configuration from vendor: And change the shopget operation in copied config/apiplatform/Adjustment.xml file: Update your API platform paths config if needed so the new configuration file is loaded:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-55rf-8q29-4g43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-40633

Advisory: Sylius has a security vulnerability via adjustments API endpoint
IDs: CVE-2024-40633, GHSA-55rf-8q29-4g43
Record: https://patchnext.com/advisories/cve-2024-40633 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.13.4, 1.12.19, 1.11.17, 1.10.16, 1.9.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected >= 1.13.0-alpha.1, < 1.13.4; >= 1.12.0-alpha.1, < 1.12.19; < 1.9.12; >= 1.10.0-alpha.1, <= 1.10.15; >= 1.11.0-alpha.1, <= 1.11.16; fixed in 1.10.16, 1.11.17, 1.13.4, 1.9.12, 1.12.19

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-55rf-8q29-4g43 (GitHub-reviewed advisory GHSA-55rf-8q29-4g43 lists affected ranges: Packagist sylius/sylius >=1.13.0-alpha.1 =1.12.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <=1.11.16)

Commands are suggestions: review each one before running it.

Loading voting…