Plate media plugins has a XSS in media embed element when using custom URL parsers
CVE-2024-40631GHSA-h3pq-667x-r789
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@udecode/plate-media 36.0.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 36.0.10
- Fixed in
- 36.0.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h3pq-667x-r789 lists affected ranges: npm @udecode/plate-media >=0 <36.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h3pq-667x-r789 lists affected ranges: npm @udecode/plate-media >=0 <36.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-40631: 0.50% estimated exploitation activity in the next 30 days; percentile 42.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Editors that use MediaEmbedElement and pass custom urlParsers to the useMediaState hook may be vulnerable to XSS if a custom parser allows javascript:, data: or vbscript: URLs to be embedded. Editors that do not use urlParsers and instead consume the url property directly may also be vulnerable if the URL is not sanitised. The default parsers parseTwitterUrl and parseVideoUrl are not affected. Examples of vulnerable code: Patches @udecode/plate-media 36.0.10 resolves this issue by only allowing HTTP and HTTPS URLs during parsing. This affects only the embed property returned from useMediaState. In addition, the url property returned from useMediaState has been renamed to unsafeUrl to indicate that it has not been sanitised. The url property on element is also unsafe, but has not been renamed. If you're using either of these properties directly, you will still need to validate the URL yourself. Workarounds Ensure that any custom urlParsers do not allow javascript:, data: or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h3pq-667x-r789
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h3pq-667x-r789
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-40631 Advisory: Plate media plugins has a XSS in media embed element when using custom URL parsers IDs: CVE-2024-40631, GHSA-h3pq-667x-r789 Record: https://patchnext.com/advisories/cve-2024-40631 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @udecode/plate-media 36.0.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @udecode/plate-media: affected < 36.0.10; fixed in 36.0.10 ## Suggested inspection (read-only) - `npm ls @udecode/plate-media --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @udecode/plate-media. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h3pq-667x-r789 (OSV record GHSA-h3pq-667x-r789 lists affected ranges: npm @udecode/plate-media >=0 <36.0.10 (fixed)) - Verified: https://github.com/advisories/GHSA-h3pq-667x-r789 (GitHub-reviewed advisory GHSA-h3pq-667x-r789 lists affected ranges: npm @udecode/plate-media >=0 <36.0.10) Commands are suggestions: review each one before running it.
Loading voting…