OpaMiddleware does not filter HTTP OPTIONS requests
CVE-2024-40627GHSA-5f5c-8rvc-j8wf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-opa 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fastapi-opa
- Affected
- < 2.0.1
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5f5c-8rvc-j8wf lists affected ranges: PyPI fastapi-opa >=0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5f5c-8rvc-j8wf lists affected ranges: PyPI fastapi-opa >=0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2024-40627: 0.56% estimated exploitation activity in the next 30 days; percentile 46.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary HTTP OPTIONS requests are always allowed by OpaMiddleware, even when they lack authentication, and are passed through directly to the application. The maintainer uncertain whether this should be classed as a "bug" or "security issue" – but is erring on the side of "security issue" as an application could reasonably assume OPA controls apply to all HTTP methods, and it bypasses more sophisticated policies. Details OpaMiddleware allows all HTTP OPTIONS requests without evaluating it against any policy: https://github.com/busykoala/fastapi-opa/blob/6dd6f8c87e908fe080784a74707f016f1422b58a/fastapiopa/opa/opamiddleware.py#L79-L80 If an application provides different responses to HTTP OPTIONS requests based on an entity existing (such as to indicate whether an entity is writable on a system level), an unauthenticated attacker could discover which entities exist within an application (CWE-204). PoC This toy application is based on the behaviour of an app[^1] which can use…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5f5c-8rvc-j8wf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5f5c-8rvc-j8wf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-40627 Advisory: OpaMiddleware does not filter HTTP OPTIONS requests IDs: CVE-2024-40627, GHSA-5f5c-8rvc-j8wf Record: https://patchnext.com/advisories/cve-2024-40627 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastapi-opa 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fastapi-opa: affected < 2.0.1; fixed in 2.0.1 ## Suggested inspection (read-only) - `python -m pip show fastapi-opa`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastapi-opa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5f5c-8rvc-j8wf (OSV record GHSA-5f5c-8rvc-j8wf lists affected ranges: PyPI fastapi-opa >=0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5f5c-8rvc-j8wf (GitHub-reviewed advisory GHSA-5f5c-8rvc-j8wf lists affected ranges: PyPI fastapi-opa >=0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…