EGroupware mishandles an ORDER BY clause
CVE-2024-40614GHSA-phg7-8mm9-gj88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (egroupware/egroupware 23.1.20240624), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist egroupware/egroupware
- Affected
- < 23.1.20240624
- Fixed in
- 23.1.20240624
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-phg7-8mm9-gj88 lists affected ranges: Packagist egroupware/egroupware >=0 <23.1.20240624
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-40614: 0.68% estimated exploitation activity in the next 30 days; percentile 52.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
EGroupware before 23.1.20240624 mishandles an ORDER BY clause. This leads to json.php menuaction=EGroupware\Api\Etemplate\Widget\Nextmatch::ajaxgetrows sort.id SQL injection by authenticated users for Address Book or InfoLog sorting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-phg7-8mm9-gj88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-40614 Advisory: EGroupware mishandles an ORDER BY clause IDs: CVE-2024-40614, GHSA-phg7-8mm9-gj88 Record: https://patchnext.com/advisories/cve-2024-40614 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: egroupware/egroupware 23.1.20240624. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist egroupware/egroupware: affected < 23.1.20240624; fixed in 23.1.20240624 ## Suggested inspection (read-only) - Packagist egroupware/egroupware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on egroupware/egroupware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-phg7-8mm9-gj88 (GitHub-reviewed advisory GHSA-phg7-8mm9-gj88 lists affected ranges: Packagist egroupware/egroupware >=0 <23.1.20240624) Commands are suggestions: review each one before running it.
Loading voting…