Gogs has an argument Injection in the built-in SSH server
CVE-2024-39930GHSA-vm62-9jw3-c8w3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go gogs.io/gogs
- Affected
- <= 0.13.0
- Fixed in
- 0.13.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vm62-9jw3-c8w3 lists affected ranges: Go gogs.io/gogs >=0 <=0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:L/S:C/UI:N
- EPSS
- CVE-2024-39930: 7.74% estimated exploitation activity in the next 30 days; percentile 94.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When the built-in SSH server is enabled ([server] STARTSSHSERVER = true), unprivileged user accounts with at least one SSH key can execute arbitrary commands on the Gogs instance with the privileges of the user specified by RUNUSER in the configuration. It allows attackers to access and alter any users' code hosted on the same instance. Patches The env command sent to the internal SSH server has been changed to be a passthrough (https://github.com/gogs/gogs/pull/7868), i.e. the feature is effectively removed. Users should upgrade to 0.13.1 or the latest 0.14.0+dev. Workarounds Disable the use of built-in SSH server on operating systems other than Windows. References https://www.cve.org/CVERecord?id=CVE-2024-39930
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vm62-9jw3-c8w3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39930 Advisory: Gogs has an argument Injection in the built-in SSH server IDs: CVE-2024-39930, GHSA-vm62-9jw3-c8w3 Record: https://patchnext.com/advisories/cve-2024-39930 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go gogs.io/gogs: affected <= 0.13.0; fixed in 0.13.1 ## Suggested inspection (read-only) - Go gogs.io/gogs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gogs.io/gogs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vm62-9jw3-c8w3 (GitHub-reviewed advisory GHSA-vm62-9jw3-c8w3 lists affected ranges: Go gogs.io/gogs >=0 <=0.13.0) Commands are suggestions: review each one before running it.
Loading voting…