1Panel has an SQL injection issue related to the orderBy clause
CVE-2024-39907GHSA-5grx-v727-qmq6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/1Panel-dev/1Panel 1.10.12-tls), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/1Panel-dev/1Panel
- Affected
- < 1.10.12-tls
- Fixed in
- 1.10.12-tls
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5grx-v727-qmq6 lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <1.10.12-tls
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-39907: 29.18% estimated exploitation activity in the next 30 days; percentile 98.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There are many sql injections in the project, and some of them are not well filtered, leading to arbitrary file writes, and ultimately leading to RCEs. The proof is as follows Details (one of them ) <img width="697" alt="image" src="https://github.com/1Panel-dev/1Panel/assets/129351704/895b7b43-9bc0-44b3-9c84-24c2dcc962da" <img width="936" alt="image" src="https://github.com/1Panel-dev/1Panel/assets/129351704/1b8eb866-9865-4bef-a359-53335d709157" <img width="684" alt="image" src="https://github.com/1Panel-dev/1Panel/assets/129351704/e865d6d0-7ecb-49f7-b4a2-f1b0bc407986" PoC curl 'http://api:30455/api/v1/hosts/command/search' {"page":1,"pageSize":10,"groupID":0,"orderBy":"3","order":"ascending","name":"a"} <img width="664" alt="image" src="https://github.com/1Panel-dev/1Panel/assets/129351704/250d5a2a-cb32-44dc-9831-86dbc2f2b43f" for example as picture . just change orderby‘s num we can know How many columns does the data table have.Parameters require strict whitelist…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5grx-v727-qmq6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39907 Advisory: 1Panel has an SQL injection issue related to the orderBy clause IDs: CVE-2024-39907, GHSA-5grx-v727-qmq6 Record: https://patchnext.com/advisories/cve-2024-39907 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/1Panel-dev/1Panel 1.10.12-tls. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/1Panel-dev/1Panel: affected < 1.10.12-tls; fixed in 1.10.12-tls ## Suggested inspection (read-only) - Go github.com/1Panel-dev/1Panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/1Panel-dev/1Panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5grx-v727-qmq6 (GitHub-reviewed advisory GHSA-5grx-v727-qmq6 lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <1.10.12-tls) Commands are suggestions: review each one before running it.
Loading voting…