Skip to content

← Actionable
Medium, CVSS 6.9amended

Red-DiscordBot vulnerable to Incorrect Authorization in commands API

CVE-2024-39905GHSA-5jq8-q6rj-9gq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (red-discordbot 3.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-39905: 0.41% estimated exploitation activity in the next 30 days; percentile 35.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Due to a bug in Red's Core API, 3rd-party cogs using the @commands.canmanagechannel() command permission check without additional permission controls may authorize a user to run a command even when that user doesn't have permissions to manage a channel. None of the core commands or core cogs are affected. The maintainers of the project are not aware of any public 3rd-party cog utilizing this API at the time of writing this advisory. The @commands.modorcanmanagechannel(), @commands.adminorcanmanagechannel(), and @commands.guildownerorcanmanagechannel() command permission checks are unaffected. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N/AU:Y/R:U/RE:L Patches The problem was patched in PR #6398 and later released in version 3.5.10. Workarounds Any cog using the @commands.canmanagechannel() command permission check should be unloaded until an upgrade to a patched version can be performed. References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5jq8-q6rj-9gq4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5jq8-q6rj-9gq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39905

Advisory: Red-DiscordBot vulnerable to Incorrect Authorization in commands API
IDs: CVE-2024-39905, GHSA-5jq8-q6rj-9gq4
Record: https://patchnext.com/advisories/cve-2024-39905 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: red-discordbot 3.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI red-discordbot: affected >= 3.5.0, < 3.5.10; fixed in 3.5.10

## Suggested inspection (read-only)
- `python -m pip show red-discordbot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on red-discordbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5jq8-q6rj-9gq4 (OSV record GHSA-5jq8-q6rj-9gq4 lists affected ranges: PyPI red-discordbot >=3.5.0 <3.5.10 (fixed))
- Verified: https://github.com/advisories/GHSA-5jq8-q6rj-9gq4 (GitHub-reviewed advisory GHSA-5jq8-q6rj-9gq4 lists affected ranges: PyPI red-discordbot >=3.5.0 <3.5.10)

Commands are suggestions: review each one before running it.

Loading voting…