Local File Inclusion in Solara
CVE-2024-39903GHSA-9794-pc4r-438w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (solara 1.35.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI solara
- Affected
- < 1.35.1
- Fixed in
- 1.35.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9794-pc4r-438w lists affected ranges: PyPI solara >=0 <1.35.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9794-pc4r-438w lists affected ranges: PyPI solara >=0 <1.35.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2024-39903: 2.88% estimated exploitation activity in the next 30 days; percentile 86.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Local File Inclusion (LFI) vulnerability was identified in widgetti/solara, in version <1.35.1, which was fixed in version 1.35.1. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../' when serving static files. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system. References - https://github.com/widgetti/solara/security/advisories/GHSA-9794-pc4r-438w - https://github.com/widgetti/solara/commit/df2fd66a7f4e8ffd36e8678697a8a4f76760dc54 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-39903
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9794-pc4r-438w
- Revision 1 · created ·
Published from osv record GHSA-9794-pc4r-438w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39903 Advisory: Local File Inclusion in Solara IDs: CVE-2024-39903, GHSA-9794-pc4r-438w Record: https://patchnext.com/advisories/cve-2024-39903 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: solara 1.35.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI solara: affected < 1.35.1; fixed in 1.35.1 ## Suggested inspection (read-only) - `python -m pip show solara`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on solara. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9794-pc4r-438w (OSV record GHSA-9794-pc4r-438w lists affected ranges: PyPI solara >=0 <1.35.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9794-pc4r-438w (GitHub-reviewed advisory GHSA-9794-pc4r-438w lists affected ranges: PyPI solara >=0 <1.35.1) Commands are suggestions: review each one before running it.
Loading voting…