Skip to content

← Actionable
Low, CVSS 2.3

OpenSearch Observability does not properly restrict access to private tenant resources

CVE-2024-39901GHSA-77vc-rj32-2r33

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-observability 2.14.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-39901: 0.29% estimated exploitation activity in the next 30 days; percentile 21.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An issue in the OpenSearch observability plugins allows unintended access to private tenant resources like notebooks. The system did not properly check if the user was the resource author when accessing resources in a private tenant, leading to potential data being revealed. Impact The lack of proper access control validation for private tenant resources in the OpenSearch observability and reporting plugins can lead to unintended data access. If an authorized user with observability or reporting roles is aware of another user's private tenant resource ID, such as a notebook, they can potentially read, modify, or take ownership of that resource, despite not being the original author, thus impacting the confidentiality and integrity of private tenant resources. The impact is confined to private tenant resources, where authorized users may gain inappropriate visibility into data intended to be private from other users within the same OpenSearch instance, potentially violating…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-77vc-rj32-2r33

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39901

Advisory: OpenSearch Observability does not properly restrict access to private tenant resources
IDs: CVE-2024-39901, GHSA-77vc-rj32-2r33
Record: https://patchnext.com/advisories/cve-2024-39901 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-observability 2.14.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.plugin:opensearch-observability: affected < 2.14.0.0; fixed in 2.14.0.0

## Suggested inspection (read-only)
- Maven org.opensearch.plugin:opensearch-observability: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.plugin:opensearch-observability.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-77vc-rj32-2r33 (GitHub-reviewed advisory GHSA-77vc-rj32-2r33 lists affected ranges: Maven org.opensearch.plugin:opensearch-observability >=0 <2.14.0.0)

Commands are suggestions: review each one before running it.

Loading voting…