Skip to content

← Actionable
High, CVSS 7.1amended

Directus GraphQL Field Duplication Denial of Service (DoS)

CVE-2024-39895GHSA-7hmh-pfrp-vcx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@directus/env 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-39895: 0.80% estimated exploitation activity in the next 30 days; percentile 56.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A denial of service (DoS) attack by field duplication in GraphQL is a type of attack where an attacker exploits the flexibility of GraphQL to overwhelm a server by requesting the same field multiple times in a single query. This can cause the server to perform redundant computations and consume excessive resources, leading to a denial of service for legitimate users. Details Request to the endpoint /graphql are sent when visualizing graphs generated at a dashboard: By modifying the data sent and duplicating many times the fields a DoS attack is possible. PoC The goal is to create a payload that generates a body like this, where the 'max' field is duplicated many times, each with the 'id' field duplicated many times inside it. {'query': 'query { query4f4722ea: testtableaggregated { max {id id id id id id id id id id } max {id id id id id id id id id id } max {id id id id id id id id id id } max {id id id id id id id id id id } max {id id id id id id id id id id } max {id id id…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7hmh-pfrp-vcx4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7hmh-pfrp-vcx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39895

Advisory: Directus GraphQL Field Duplication Denial of Service (DoS)
IDs: CVE-2024-39895, GHSA-7hmh-pfrp-vcx4
Record: https://patchnext.com/advisories/cve-2024-39895 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @directus/env 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @directus/env: affected < 1.1.6; fixed in 1.1.6

## Suggested inspection (read-only)
- `npm ls @directus/env --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @directus/env.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7hmh-pfrp-vcx4 (OSV record GHSA-7hmh-pfrp-vcx4 lists affected ranges: npm @directus/env >=0 <1.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-7hmh-pfrp-vcx4 (GitHub-reviewed advisory GHSA-7hmh-pfrp-vcx4 lists affected ranges: npm @directus/env >=0 <1.1.6)

Commands are suggestions: review each one before running it.

Loading voting…