Skip to content

← Actionable
Low, CVSS 3.8

Mattermost did not properly restrict channel creation

CVE-2024-39837GHSA-vvpg-55p7-5h8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 9.9.1, 9.5.7, 8.0.0-20240626164322-c758cecaf30c; github.com/mattermost/mattermost-server/v6 6.0.0-20240626164322-c758cecaf30c; github.com/mattermost/mattermost-server 9.9.1, 9.5.7; github.com/mattermost/mattermost-server/v5 5.3.2-0.20240626164322-c758cecaf30c), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-vvpg-55p7-5h8w lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.5.0 =9.9.0 =0 =9.9.0 =9.5.0 =0 =0 <6.0.0-20240626164322-c758cecaf30c

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-39837: 0.28% estimated exploitation activity in the next 30 days; percentile 20.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly restrict channel creation which allows a malicious remote to create arbitrary channels, when shared channels were enabled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vvpg-55p7-5h8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39837

Advisory: Mattermost did not properly restrict channel creation
IDs: CVE-2024-39837, GHSA-vvpg-55p7-5h8w
Record: https://patchnext.com/advisories/cve-2024-39837 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 9.9.1, 9.5.7, 8.0.0-20240626164322-c758cecaf30c; github.com/mattermost/mattermost-server/v6 6.0.0-20240626164322-c758cecaf30c; github.com/mattermost/mattermost-server 9.9.1, 9.5.7; github.com/mattermost/mattermost-server/v5 5.3.2-0.20240626164322-c758cecaf30c. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 9.5.0, < 9.5.7; >= 9.9.0, <= 9.9.0; < 8.0.0-20240626164322-c758cecaf30c; fixed in 9.9.1, 9.5.7, 8.0.0-20240626164322-c758cecaf30c
- Go github.com/mattermost/mattermost-server/v6: affected < 6.0.0-20240626164322-c758cecaf30c; fixed in 6.0.0-20240626164322-c758cecaf30c
- Go github.com/mattermost/mattermost-server: affected >= 9.9.0, <= 9.9.0; >= 9.5.0, < 9.5.7; fixed in 9.9.1, 9.5.7
- Go github.com/mattermost/mattermost-server/v5: affected < 5.3.2-0.20240626164322-c758cecaf30c; fixed in 5.3.2-0.20240626164322-c758cecaf30c

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vvpg-55p7-5h8w (GitHub-reviewed advisory GHSA-vvpg-55p7-5h8w lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.5.0 =9.9.0 =0 =9.9.0 =9.5.0 =0 =0 <6.0.0-20240626164322-c758cecaf30c)

Commands are suggestions: review each one before running it.

Loading voting…