Skip to content

← Actionable
High, CVSS 8.8

Ollama Out-of-bounds Read

CVE-2024-39720GHSA-95j2-w8x7-hm88

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ollama/ollama 0.1.46), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-39720: 2.44% estimated exploitation activity in the next 30 days; percentile 84.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Ollama before 0.1.46. An attacker can use two HTTP requests to upload a malformed GGUF file containing just 4 bytes starting with the GGUF custom magic header. By leveraging a custom Modelfile that includes a FROM statement pointing to the attacker-controlled blob file, the attacker can crash the application through the CreateModel route, leading to a segmentation fault (signal SIGSEGV: segmentation violation).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-95j2-w8x7-hm88

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39720

Advisory: Ollama Out-of-bounds Read
IDs: CVE-2024-39720, GHSA-95j2-w8x7-hm88
Record: https://patchnext.com/advisories/cve-2024-39720 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ollama/ollama 0.1.46. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ollama/ollama: affected < 0.1.46; fixed in 0.1.46

## Suggested inspection (read-only)
- Go github.com/ollama/ollama: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ollama/ollama.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-95j2-w8x7-hm88 (GitHub-reviewed advisory GHSA-95j2-w8x7-hm88 lists affected ranges: Go github.com/ollama/ollama >=0 <0.1.46)

Commands are suggestions: review each one before running it.

Loading voting…