Skip to content

← Actionable
High, CVSS 7.0amended

Directus incorrectly handles _in filter

CVE-2024-39701GHSA-hxgm-ghmv-xjjm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 9.23.0, <= 10.5.3
    Fixed in
    10.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-39701: 0.42% estimated exploitation activity in the next 30 days; percentile 36.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Directus =9.23.0, <=v10.5.3 improperly handles in, nin operators. It evaluates empty arrays as valid so expressions like {"role": {"in": $CURRENTUSER.somefield}} would evaluate to true allowing the request to pass. Details This results in Broken Access Control because the rule fails to do what it was intended to do: Pass rule if field matches any of the values. ref: https://docs.directus.io/reference/filter-rules.html#filter-operators In my example this would translate to "Pass rule if <collection.role matches any of []". Which should fail. This instead passes in Directus <= v10.5.3, =v9.23.0 PoC {"role": {"in": $CURRENTUSER.somefield}} field validation would pass if $CURRENTUSER.somefield is null. Real scenario: Using https://github.com/u12206050/directus-extension-role-chooser with the specified versions of Directus (I tested on 10.0.0) allows users with access to this feature set their role to whatever role if they don't have any roles assigned (userroles.role is left with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hxgm-ghmv-xjjm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hxgm-ghmv-xjjm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39701

Advisory: Directus incorrectly handles `_in` filter
IDs: CVE-2024-39701, GHSA-hxgm-ghmv-xjjm
Record: https://patchnext.com/advisories/cve-2024-39701 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 9.23.0, <= 10.5.3; fixed in 10.6.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hxgm-ghmv-xjjm (OSV record GHSA-hxgm-ghmv-xjjm lists affected ranges: npm directus >=9.23.0 <10.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hxgm-ghmv-xjjm (GitHub-reviewed advisory GHSA-hxgm-ghmv-xjjm lists affected ranges: npm directus >=9.23.0 <=10.5.3)

Commands are suggestions: review each one before running it.

Loading voting…