electron-updater Code Signing Bypass on Windows
CVE-2024-39698GHSA-9jxc-qjr9-vjxq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron-updater 6.3.0-alpha.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron-updater
- Affected
- <= 6.3.0-alpha.5
- Fixed in
- 6.3.0-alpha.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9jxc-qjr9-vjxq lists affected ranges: npm electron-updater >=0 <6.3.0-alpha.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jxc-qjr9-vjxq lists affected ranges: npm electron-updater >=0 <=6.3.0-alpha.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-39698: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Observations The file packages/electron-updater/src/windowsExecutableCodeSignatureVerifier.ts implements the signature validation routine for Electron applications on Windows. It executes the following command in a new shell (process.env.ComSpec on Windows, usually C:\Windows\System32\cmd.exe): https://github.com/electron-userland/electron-builder/blob/140e2f0eb0df79c2a46e35024e96d0563355fc89/packages/electron-updater/src/windowsExecutableCodeSignatureVerifier.ts#L35-L41 Because of the surrounding shell, a first pass by cmd.exe expands any environment variable found in command-line above. Exploitation This creates a situation where verifySignature() can be tricked into validating the certificate of a different file than the one that was just downloaded. If the step is successful, the malicious update will be executed even if its signature is invalid. Impact This attack assumes a compromised update manifest (server compromise, Man-in-the-Middle attack if fetched over HTTP, Cross-Site…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9jxc-qjr9-vjxq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9jxc-qjr9-vjxq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39698 Advisory: electron-updater Code Signing Bypass on Windows IDs: CVE-2024-39698, GHSA-9jxc-qjr9-vjxq Record: https://patchnext.com/advisories/cve-2024-39698 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron-updater 6.3.0-alpha.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron-updater: affected <= 6.3.0-alpha.5; fixed in 6.3.0-alpha.6 ## Suggested inspection (read-only) - `npm ls electron-updater --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron-updater. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9jxc-qjr9-vjxq (OSV record GHSA-9jxc-qjr9-vjxq lists affected ranges: npm electron-updater >=0 <6.3.0-alpha.6 (fixed)) - Verified: https://github.com/advisories/GHSA-9jxc-qjr9-vjxq (GitHub-reviewed advisory GHSA-9jxc-qjr9-vjxq lists affected ranges: npm electron-updater >=0 <=6.3.0-alpha.5) Commands are suggestions: review each one before running it.
Loading voting…