Skip to content

← Actionable
Medium, CVSS 5.1

IdentityServer Open Redirect vulnerability

CVE-2024-39694GHSA-ff4q-64jc-gx98

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet duende.identityserver

    Affected
    >= 7.0.0-preview.1, <= 7.0.5>= 6.3.0-preview.1, <= 6.3.9>= 6.2.0-preview.1, <= 6.2.4>= 6.1.0-preview.1, <= 6.1.7>= 6.0.0-preview.1, <= 6.0.4
    Fixed in
    6.3.10, 6.1.8, 6.2.5, 7.0.6, 6.0.5
  • NuGet identityserver4

    Affected
    <= 4.1.2
    Fixed in
    no fixed version recorded

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-ff4q-64jc-gx98 lists affected ranges: NuGet duende.identityserver >=7.0.0-preview.1 =6.3.0-preview.1 =6.2.0-preview.1 =6.1.0-preview.1 =6.0.0-preview.1 =0 <=4.1.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2024-39694: 0.53% estimated exploitation activity in the next 30 days; percentile 45.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It is possible for an attacker to craft malicious Urls that certain functions in IdentityServer will incorrectly treat as local and trusted. If such a Url is returned as a redirect, some browsers will follow it to a third-party, untrusted site. Note: by itself, this vulnerability does not allow an attacker to obtain user credentials, authorization codes, access tokens, refresh tokens, or identity tokens. An attacker could however exploit this vulnerability as part of a phishing attack designed to steal user credentials. Affected Methods - In the DefaultIdentityServerInteractionService, the GetAuthorizationContextAsync method may return non-null and the IsValidReturnUrl method may return true for malicious Urls, indicating incorrectly that they can be safely redirected to. UI code calling these two methods is the most commonly used code path that will expose the vulnerability. The default UI templates rely on this behavior in the Login, Challenge, Consent, and Account Creation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ff4q-64jc-gx98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39694

Advisory: IdentityServer Open Redirect vulnerability
IDs: CVE-2024-39694, GHSA-ff4q-64jc-gx98
Record: https://patchnext.com/advisories/cve-2024-39694 (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: duende.identityserver 7.0.6, 6.3.10, 6.2.5, 6.1.8, 6.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet duende.identityserver: affected >= 7.0.0-preview.1, <= 7.0.5; >= 6.3.0-preview.1, <= 6.3.9; >= 6.2.0-preview.1, <= 6.2.4; >= 6.1.0-preview.1, <= 6.1.7; >= 6.0.0-preview.1, <= 6.0.4; fixed in 6.3.10, 6.1.8, 6.2.5, 7.0.6, 6.0.5
- NuGet identityserver4: affected <= 4.1.2

## Suggested inspection (read-only)
- NuGet duende.identityserver: check the installed version with your package manager.
- NuGet identityserver4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on duende.identityserver, identityserver4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ff4q-64jc-gx98 (GitHub-reviewed advisory GHSA-ff4q-64jc-gx98 lists affected ranges: NuGet duende.identityserver >=7.0.0-preview.1 =6.3.0-preview.1 =6.2.0-preview.1 =6.1.0-preview.1 =6.0.0-preview.1 =0 <=4.1.2)

Commands are suggestions: review each one before running it.

Loading voting…