Skip to content

← Actionable
Medium, CVSS 6.9amended

Server Side Request Forgery (SSRF) attack in Fedify

CVE-2024-39687GHSA-p9cg-vqcc-grcx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 0.11.2, 0.10.2, 0.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @fedify/fedify

    Affected
    < 0.9.2>= 0.10.0, < 0.10.2>= 0.11.0, < 0.11.2
    Fixed in
    0.11.2, 0.9.2, 0.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L · score source
EPSS
  • CVE-2024-39687: 0.60% estimated exploitation activity in the next 30 days; percentile 48.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary At present, when Fedify needs to retrieve an object or activity from a remote activitypub server, it makes a HTTP request to the @id or other resources present within the activity it has received from the web. This activity could reference an @id that points to an internal IP address, allowing an attacker to send request to resources internal to the fedify server's network. This applies to not just resolution of documents containing activities or objects, but also to media URLs as well. Specifically this is a Server Side Request Forgery attack. You can learn more about SSRF attacks via CWE-918 Details When Fedify makes a request at runtime via the DocLoader [1] [2], the fetch API does not first check the URI's to assert that it resolve to a public IP address. Additionally, any downstream software of Fedify that may fetch data from URIs contained within Activities or Objects maybe be at risk of requesting non-public resources, and storing those, exposing non-public information…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p9cg-vqcc-grcx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p9cg-vqcc-grcx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39687

Advisory: Server Side Request Forgery (SSRF) attack in Fedify
IDs: CVE-2024-39687, GHSA-p9cg-vqcc-grcx
Record: https://patchnext.com/advisories/cve-2024-39687 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 0.11.2, 0.10.2, 0.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fedify/fedify: affected < 0.9.2; >= 0.10.0, < 0.10.2; >= 0.11.0, < 0.11.2; fixed in 0.11.2, 0.9.2, 0.10.2

## Suggested inspection (read-only)
- `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fedify/fedify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p9cg-vqcc-grcx (OSV record GHSA-p9cg-vqcc-grcx lists affected ranges: npm @fedify/fedify >=0 =0.10.0 =0.11.0 <0.11.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p9cg-vqcc-grcx (GitHub-reviewed advisory GHSA-p9cg-vqcc-grcx lists affected ranges: npm @fedify/fedify >=0 =0.10.0 =0.11.0 <0.11.2)

Commands are suggestions: review each one before running it.

Loading voting…