Wagtail regular expression denial-of-service via search query parsing
CVE-2024-39317GHSA-jmp3-39vp-fwg8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 6.1.3, 6.0.6, 5.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- >= 6.0, < 6.0.6>= 6.1, < 6.1.3>= 2.0, < 5.2.6
- Fixed in
- 6.1.3, 5.2.6, 6.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jmp3-39vp-fwg8 lists affected ranges: PyPI wagtail >=6.0 =6.1 =2.0 <5.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jmp3-39vp-fwg8 lists affected ranges: PyPI wagtail >=6.0 =6.1 =2.0 <5.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-39317: 0.61% estimated exploitation activity in the next 30 days; percentile 49.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A bug in Wagtail's parsequerystring would result in it taking a long time to process suitably crafted inputs. When used to parse sufficiently long strings of characters without a space, parsequerystring would take an unexpectedly large amount of time to process, resulting in a denial of service. In an initial Wagtail installation, the vulnerability can be exploited by any Wagtail admin user. It cannot be exploited by end users. If your Wagtail site has a custom search implementation which uses parsequerystring, it may be exploitable by other users (e.g. unauthenticated users). Patches Patched versions have been released as Wagtail 5.2.6, 6.0.6 and 6.1.3. This vulnerability affects all unpatched versions from Wagtail 2.0 onwards. Workarounds Site owners who are unable to upgrade to a patched version can limit the length of search terms passed to parsequerystring. Whilst the performance characteristics will depend on your hosting environment, 1000 characters has been shown to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jmp3-39vp-fwg8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jmp3-39vp-fwg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39317 Advisory: Wagtail regular expression denial-of-service via search query parsing IDs: CVE-2024-39317, GHSA-jmp3-39vp-fwg8 Record: https://patchnext.com/advisories/cve-2024-39317 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 6.1.3, 6.0.6, 5.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected >= 6.0, < 6.0.6; >= 6.1, < 6.1.3; >= 2.0, < 5.2.6; fixed in 6.1.3, 5.2.6, 6.0.6 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jmp3-39vp-fwg8 (OSV record GHSA-jmp3-39vp-fwg8 lists affected ranges: PyPI wagtail >=6.0 =6.1 =2.0 <5.2.6 (fixed)) - Verified: https://github.com/advisories/GHSA-jmp3-39vp-fwg8 (GitHub-reviewed advisory GHSA-jmp3-39vp-fwg8 lists affected ranges: PyPI wagtail >=6.0 =6.1 =2.0 <5.2.6) Commands are suggestions: review each one before running it.
Loading voting…