Skip to content

← Actionable
Medium, CVSS 6.5

Rack ReDoS Vulnerability in HTTP Accept Headers Parsing

CVE-2024-39316GHSA-cj83-2ww7-mvq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    >= 3.1.0, < 3.1.5
    Fixed in
    3.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-39316: 0.86% estimated exploitation activity in the next 30 days; percentile 58.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Regular Expression Denial of Service (ReDoS) vulnerability exists in the Rack::Request::Helpers module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending specially crafted Accept-Encoding or Accept-Language headers, causing the server to spend excessive time processing the request and leading to a Denial of Service (DoS). Details The fix for https://github.com/rack/rack/security/advisories/GHSA-54rr-7fvw-6x8f was not applied to the main branch and thus while the issue was fixed for the Rack v3.0 release series, it was not fixed in the v3.1 release series until v3.1.5.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cj83-2ww7-mvq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39316

Advisory: Rack ReDoS Vulnerability in HTTP Accept Headers Parsing
IDs: CVE-2024-39316, GHSA-cj83-2ww7-mvq7
Record: https://patchnext.com/advisories/cve-2024-39316 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 3.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected >= 3.1.0, < 3.1.5; fixed in 3.1.5

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cj83-2ww7-mvq7 (GitHub-reviewed advisory GHSA-cj83-2ww7-mvq7 lists affected ranges: RubyGems rack >=3.1.0 <3.1.5)

Commands are suggestions: review each one before running it.

Loading voting…