Skip to content

← Actionable
Medium, CVSS 6.1

RailsAdmin Cross-site Scripting vulnerability in the list view

CVE-2024-39308GHSA-8qgm-g2vv-vwvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails_admin 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rails_admin

    Affected
    >= 3.0.0.beta, < 3.1.3
    Fixed in
    3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-39308: 0.58% estimated exploitation activity in the next 30 days; percentile 47.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. The issue was originally reported in https://github.com/railsadminteam/railsadmin/issues/3686. Patches Upgrade to 3.1.4. The vulnerability itself was patched in 3.1.3 but it has a functionality issue. Initially the vulnerability was thought to exist in versions before 3.0, but it didn't. 2.x users can stay on 2.2.1. Workarounds 1. Copy the index view (located under the path app/views/railsadmin/main/index.html.erb) from the RailsAdmin version you use, and place it into your application by using the same path. 2. Open the view file by an editor, and change the way to populate the td tag: Note: The view file created by this needs to be removed after upgrading RailsAdmin afterwards, unless this old view continue to be used. Only do this if you can't upgrade RailsAdmin now for a reason. References https://owasp.org/www-community/attacks/xss/…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8qgm-g2vv-vwvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39308

Advisory: RailsAdmin Cross-site Scripting vulnerability in the list view
IDs: CVE-2024-39308, GHSA-8qgm-g2vv-vwvc
Record: https://patchnext.com/advisories/cve-2024-39308 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rails_admin 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rails_admin: affected >= 3.0.0.beta, < 3.1.3; fixed in 3.1.3

## Suggested inspection (read-only)
- RubyGems rails_admin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rails_admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qgm-g2vv-vwvc (GitHub-reviewed advisory GHSA-8qgm-g2vv-vwvc lists affected ranges: RubyGems rails_admin >=3.0.0.beta <3.1.3)

Commands are suggestions: review each one before running it.

Loading voting…