Skip to content

← Actionable
High, CVSS 8.9amended

Prototype pollution in ag-grid-community via the _.mergeDeep function

CVE-2024-38996GHSA-876p-c77m-x2hc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ag-grid-community 31.3.4; ag-grid-enterprise 31.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-38996: 1.16% estimated exploitation activity in the next 30 days; percentile 67.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ag-grid-community v31.3.2 and ag-grid-enterprise v31.3.2 were discovered to contain a prototype pollution via the .mergeDeep function. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties. Prior versions were also found to be affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-876p-c77m-x2hc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-876p-c77m-x2hc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38996

Advisory: Prototype pollution in ag-grid-community via the _.mergeDeep function
IDs: CVE-2024-38996, GHSA-876p-c77m-x2hc
Record: https://patchnext.com/advisories/cve-2024-38996 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ag-grid-community 31.3.4; ag-grid-enterprise 31.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ag-grid-community: affected < 31.3.4; fixed in 31.3.4
- npm ag-grid-enterprise: affected < 31.3.4; fixed in 31.3.4

## Suggested inspection (read-only)
- `npm ls ag-grid-community --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls ag-grid-enterprise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ag-grid-community, ag-grid-enterprise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-876p-c77m-x2hc (OSV record GHSA-876p-c77m-x2hc lists affected ranges: npm ag-grid-enterprise >=0 =0 <31.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-876p-c77m-x2hc (GitHub-reviewed advisory GHSA-876p-c77m-x2hc lists affected ranges: npm ag-grid-enterprise >=0 =0 <31.3.4)

Commands are suggestions: review each one before running it.

Loading voting…