@alizeait/unflatto Prototype Pollution
CVE-2024-38988GHSA-q8jq-4rm5-4hm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@alizeait/unflatto 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q8jq-4rm5-4hm5 lists affected ranges: npm @alizeait/unflatto >=0 <1.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q8jq-4rm5-4hm5 lists affected ranges: npm @alizeait/unflatto >=0 <1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N/E:P · score source
- EPSS
- CVE-2024-38988: 0.87% estimated exploitation activity in the next 30 days; percentile 58.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties. Patches The problem has been patched in 1.0.3 References https://github.com/advisories/GHSA-799q-f2px-wx8c
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q8jq-4rm5-4hm5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q8jq-4rm5-4hm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-38988 Advisory: @alizeait/unflatto Prototype Pollution IDs: CVE-2024-38988, GHSA-q8jq-4rm5-4hm5 Record: https://patchnext.com/advisories/cve-2024-38988 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @alizeait/unflatto 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @alizeait/unflatto: affected < 1.0.3; fixed in 1.0.3 ## Suggested inspection (read-only) - `npm ls @alizeait/unflatto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @alizeait/unflatto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q8jq-4rm5-4hm5 (OSV record GHSA-q8jq-4rm5-4hm5 lists affected ranges: npm @alizeait/unflatto >=0 <1.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-q8jq-4rm5-4hm5 (GitHub-reviewed advisory GHSA-q8jq-4rm5-4hm5 lists affected ranges: npm @alizeait/unflatto >=0 <1.0.3) Commands are suggestions: review each one before running it.
Loading voting…