Skip to content

← Actionable
Unratedamended

Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js

CVE-2024-38537GHSA-cvw4-c69g-7v7m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.39.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
0.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N
EPSS
  • CVE-2024-38537: 1.43% estimated exploitation activity in the next 30 days; percentile 73.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Note On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure polyfill.io and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. The following sections describe this vulnerability prior to the domain level intervention, when it was still exploitable. Impact fides.js, a client-side script used to interact with the consent management features of Fides, used the polyfill.io domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. On June 25th, 2024, Sansec published the following regarding the polyfill.io domain. The polyfill.js is a popular open source library to support older browsers. 100K+ sites embed it using the cdn.polyfill.io domain... However, in February this year, a Chinese company bought the domain and the Github account. Since then, this domain was caught injecting malware on mobile devices via any site that embeds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cvw4-c69g-7v7m

  2. Revision 1 · created ·

    Published from osv record GHSA-cvw4-c69g-7v7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38537

Advisory: Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js
IDs: CVE-2024-38537, GHSA-cvw4-c69g-7v7m
Record: https://patchnext.com/advisories/cve-2024-38537 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated (CVSS 0.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.39.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected < 2.39.1; fixed in 2.39.1

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cvw4-c69g-7v7m (OSV record GHSA-cvw4-c69g-7v7m lists affected ranges: PyPI ethyca-fides >=0 <2.39.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cvw4-c69g-7v7m (GitHub-reviewed advisory GHSA-cvw4-c69g-7v7m lists affected ranges: PyPI ethyca-fides >=0 <2.39.1)

Commands are suggestions: review each one before running it.

Loading voting…