Unlimited number of NTS-KE connections can crash ntpd-rs server
CVE-2024-38528GHSA-2xpx-vcmq-5f72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ntpd 1.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ntpd
- Affected
- >= 0.3.1, <= 1.1.2
- Fixed in
- 1.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xpx-vcmq-5f72 lists affected ranges: crates.io ntpd >=0.3.1 <=1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-38528: 0.72% estimated exploitation activity in the next 30 days; percentile 53.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Missing limit for accepted NTS-KE connections allows an unauthenticated remote attacker to crash ntpd-rs when an NTS-KE server is configured. Non NTS-KE server configurations, such as the default ntpd-rs configuration, are unaffected. Details Operating systems have a limit for the number of open file descriptors (which includes sockets) in a single process, e.g. 1024 on Linux by default. When ntpd-rs is configured as an NTS server, it accepts TCP connections for the NTS-KE service. If the process has reached the descriptor limit and tries to accept a new TCP connection, the accept() system call will return with the EMFILE error and cause ntpd-rs to abort. A remote attacker can open a large number of parallel TCP connections to the server to trigger this crash. The connections need to be opened quickly enough to avoid the key-exchange-timeout-ms timeout (by default 1000 milliseconds). Impact Only NTS-KE server configuration are affected. Those without an NTS-KE server…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2xpx-vcmq-5f72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-38528 Advisory: Unlimited number of NTS-KE connections can crash ntpd-rs server IDs: CVE-2024-38528, GHSA-2xpx-vcmq-5f72 Record: https://patchnext.com/advisories/cve-2024-38528 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ntpd 1.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ntpd: affected >= 0.3.1, <= 1.1.2; fixed in 1.1.3 ## Suggested inspection (read-only) - crates.io ntpd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ntpd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2xpx-vcmq-5f72 (GitHub-reviewed advisory GHSA-2xpx-vcmq-5f72 lists affected ranges: crates.io ntpd >=0.3.1 <=1.1.2) Commands are suggestions: review each one before running it.
Loading voting…