Skip to content

← Actionable
High, CVSS 7.2amended

pdoc embeds link to malicious CDN if math mode is enabled

CVE-2024-38526GHSA-5vgj-ggm4-fg62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdoc 14.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pdoc

    Affected
    < 14.5.1
    Fixed in
    14.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L
EPSS
  • CVE-2024-38526: 3.83% estimated exploitation activity in the next 30 days; percentile 90.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Documentation generated with pdoc --math linked to JavaScript files from polyfill.io. The polyfill.io CDN has been sold and now serves malicious code. Users who produce documentation with math mode should update immediately. All other users are unaffected. Patches This issue has been fixed in pdoc 14.5.1. References https://github.com/mitmproxy/pdoc/pull/703 https://sansec.io/research/polyfill-supply-chain-attack Timeline - [2024-06-25] https://sansec.io/research/polyfill-supply-chain-attack is published. - [2024-06-25 20:54 UTC] Issue reported to the pdoc project by @adhintz. - [2024-06-25 21:33 UTC] Patched version released. - [2024-06-25 21:37 UTC] Security advisory published. - [2024-06-25 23:49 UTC] CVE-2024-38526 assigned by GitHub.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5vgj-ggm4-fg62

  2. Revision 1 · created ·

    Published from osv record GHSA-5vgj-ggm4-fg62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38526

Advisory: pdoc embeds link to malicious CDN if math mode is enabled
IDs: CVE-2024-38526, GHSA-5vgj-ggm4-fg62
Record: https://patchnext.com/advisories/cve-2024-38526 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pdoc 14.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pdoc: affected < 14.5.1; fixed in 14.5.1

## Suggested inspection (read-only)
- `python -m pip show pdoc`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pdoc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5vgj-ggm4-fg62 (OSV record GHSA-5vgj-ggm4-fg62 lists affected ranges: PyPI pdoc >=0 <14.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5vgj-ggm4-fg62 (GitHub-reviewed advisory GHSA-5vgj-ggm4-fg62 lists affected ranges: PyPI pdoc >=0 <14.5.1)

Commands are suggestions: review each one before running it.

Loading voting…