Skip to content

← Actionable
High, CVSS 7.8amended

yt-dlp File system modification and RCE through improper file-extension sanitization

CVE-2024-38519GHSA-79w7-vh3h-8g4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2024.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    < 2024.7.1
    Fixed in
    2024.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-38519: 0.33% estimated exploitation activity in the next 30 days; percentile 25.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary yt-dlp does not limit the extensions of downloaded files, which could lead to arbitrary filenames being created in the download folder (and path traversal on Windows). Since yt-dlp also reads config from the working directory (and on Windows executables will be executed from the yt-dlp directory) this could lead to arbitrary code being executed. Patches yt-dlp version 2024.07.01 fixes this issue by whitelisting the allowed extensions. This means some very uncommon extensions might not get downloaded; however, it will also limit the possible exploitation surface. Workarounds It is recommended to upgrade yt-dlp to version 2024.07.01 as soon as possible, always have .%(ext)s at the end of the output template, and make sure you trust the websites that you are downloading from. Also, make sure to never download to a directory within PATH or other sensitive locations like your user directory, system32, or other binaries locations. For users not able to upgrade: - Make sure the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-79w7-vh3h-8g4j

  2. Revision 1 · created ·

    Published from osv record GHSA-79w7-vh3h-8g4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38519

Advisory: yt-dlp File system modification and RCE through improper file-extension sanitization
IDs: CVE-2024-38519, GHSA-79w7-vh3h-8g4j
Record: https://patchnext.com/advisories/cve-2024-38519 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2024.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected < 2024.7.1; fixed in 2024.7.1

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-79w7-vh3h-8g4j (OSV record GHSA-79w7-vh3h-8g4j lists affected ranges: PyPI yt-dlp >=0 <2024.07.01 (fixed))
- Verified: https://github.com/advisories/GHSA-79w7-vh3h-8g4j (GitHub-reviewed advisory GHSA-79w7-vh3h-8g4j lists affected ranges: PyPI yt-dlp >=0 <2024.7.1)

Commands are suggestions: review each one before running it.

Loading voting…