Skip to content

← Actionable
High, CVSS 8.8

Aimeos HTML client may potentially reveal sensitive information in error log

CVE-2024-38516GHSA-ppm5-jv84-2xg2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aimeos/ai-client-html 2024.04.7, 2023.10.15, 2022.10.13, 2021.10.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist aimeos/ai-client-html

    Affected
    >= 2024.04.1, < 2024.04.7>= 2023.04.1, < 2023.10.15>= 2022.04.1, < 2022.10.13>= 2021.10.1, < 2021.10.22
    Fixed in
    2023.10.15, 2021.10.22, 2024.04.7, 2022.10.13

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-ppm5-jv84-2xg2 lists affected ranges: Packagist aimeos/ai-client-html >=2024.04.1 =2023.04.1 =2022.04.1 =2021.10.1 <2021.10.22

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-38516: 0.51% estimated exploitation activity in the next 30 days; percentile 43.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Debug information can reveal sensitive information from environment variables in error log Affected platform Laravel environments with multi-vendor setups and admin access for the vendors

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ppm5-jv84-2xg2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38516

Advisory: Aimeos HTML client may potentially reveal sensitive information in error log
IDs: CVE-2024-38516, GHSA-ppm5-jv84-2xg2
Record: https://patchnext.com/advisories/cve-2024-38516 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aimeos/ai-client-html 2024.04.7, 2023.10.15, 2022.10.13, 2021.10.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist aimeos/ai-client-html: affected >= 2024.04.1, < 2024.04.7; >= 2023.04.1, < 2023.10.15; >= 2022.04.1, < 2022.10.13; >= 2021.10.1, < 2021.10.22; fixed in 2023.10.15, 2021.10.22, 2024.04.7, 2022.10.13

## Suggested inspection (read-only)
- Packagist aimeos/ai-client-html: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aimeos/ai-client-html.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ppm5-jv84-2xg2 (GitHub-reviewed advisory GHSA-ppm5-jv84-2xg2 lists affected ranges: Packagist aimeos/ai-client-html >=2024.04.1 =2023.04.1 =2022.04.1 =2021.10.1 <2021.10.22)

Commands are suggestions: review each one before running it.

Loading voting…