Skip to content

← Actionable
Medium, CVSS 5.3amended

@fastly/js-compute has a use-after-free in some host call implementations

CVE-2024-38375GHSA-mp3g-vpm9-9vqv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastly/js-compute 3.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H
EPSS
  • CVE-2024-38375: 0.27% estimated exploitation activity in the next 30 days; percentile 18.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The implementation of the following functions were determined to include a use-after-free bug: FetchEvent.client.tlsCipherOpensslName FetchEvent.client.tlsProtocol FetchEvent.client.tlsClientCertificate FetchEvent.client.tlsJA3MD5 FetchEvent.client.tlsClientHello CacheEntry.prototype.userMetadata of the fastly:cache subsystem Device.lookup of the fastly:device subsystem This bug could allow for an unintended data leak if the result of the preceding functions were sent anywhere else, and often results in a Compute service crash causing an HTTP 500 error to be returned. As all requests to Compute are isolated from one another, the only data at risk is data present for a single request. Patches This bug has been fixed in version 3.16.0 of the @fastly/js-compute package. Workarounds There are no workarounds for this bug, any use of the affected functions introduces the possibility of a data leak or crash in guest code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mp3g-vpm9-9vqv

  2. Revision 1 · created ·

    Published from osv record GHSA-mp3g-vpm9-9vqv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38375

Advisory: @fastly/js-compute has a use-after-free in some host call implementations
IDs: CVE-2024-38375, GHSA-mp3g-vpm9-9vqv
Record: https://patchnext.com/advisories/cve-2024-38375 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastly/js-compute 3.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastly/js-compute: affected >= 3.0.0, < 3.16.0; fixed in 3.16.0

## Suggested inspection (read-only)
- `npm ls @fastly/js-compute --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastly/js-compute.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mp3g-vpm9-9vqv (OSV record GHSA-mp3g-vpm9-9vqv lists affected ranges: npm @fastly/js-compute >=3.0.0 <3.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mp3g-vpm9-9vqv (GitHub-reviewed advisory GHSA-mp3g-vpm9-9vqv lists affected ranges: npm @fastly/js-compute >=3.0.0 <3.16.0)

Commands are suggestions: review each one before running it.

Loading voting…