Undici vulnerable to data leak when using response.arrayBuffer()
CVE-2024-38372GHSA-3g92-w8c5-73pq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 6.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 6.14.0, < 6.19.2
- Fixed in
- 6.19.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3g92-w8c5-73pq lists affected ranges: npm undici >=6.14.0 <6.19.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3g92-w8c5-73pq lists affected ranges: npm undici >=6.14.0 <6.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-38372: 0.47% estimated exploitation activity in the next 30 days; percentile 40.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Depending on network and process conditions of a fetch() request, response.arrayBuffer() might include portion of memory from the Node.js process. Patches This has been patched in v6.19.2. Workarounds There are no known workaround. References https://github.com/nodejs/undici/issues/3337 https://github.com/nodejs/undici/issues/3328 https://github.com/nodejs/undici/pull/3338 https://github.com/nodejs/undici/commit/f979ec3204ca489abf30e7d20e9fee9ea7711d36
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3g92-w8c5-73pq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3g92-w8c5-73pq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-38372 Advisory: Undici vulnerable to data leak when using response.arrayBuffer() IDs: CVE-2024-38372, GHSA-3g92-w8c5-73pq Record: https://patchnext.com/advisories/cve-2024-38372 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 6.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 6.14.0, < 6.19.2; fixed in 6.19.2 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3g92-w8c5-73pq (OSV record GHSA-3g92-w8c5-73pq lists affected ranges: npm undici >=6.14.0 <6.19.2 (fixed)) - Verified: https://github.com/advisories/GHSA-3g92-w8c5-73pq (GitHub-reviewed advisory GHSA-3g92-w8c5-73pq lists affected ranges: npm undici >=6.14.0 <6.19.2) Commands are suggestions: review each one before running it.
Loading voting…