Skip to content

← Actionable
Medium, CVSS 5.3amended

TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option

CVE-2024-38356GHSA-9hcv-j9pv-qmph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-tinymce 4.1.0; tinymce 7.2.0, 6.8.4, 5.11.0; tinymce/tinymce 7.2.0, 6.8.4, 5.11.0; tinymce 7.2.0, 6.8.4, 5.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI django-tinymce

    Affected
    <= 4.0.0
    Fixed in
    4.1.0
  • NuGet tinymce

    Affected
    < 5.11.0>= 6.0.0, < 6.8.4>= 7.0.0, < 7.2.0
    Fixed in
    6.8.4, 7.2.0, 5.11.0
  • Packagist tinymce/tinymce

    Affected
    < 5.11.0>= 6.0.0, < 6.8.4>= 7.0.0, < 7.2.0
    Fixed in
    6.8.4, 7.2.0, 5.11.0
  • npm tinymce

    Affected
    < 5.11.0>= 6.0.0, < 6.8.4>= 7.0.0, < 7.2.0
    Fixed in
    6.8.4, 7.2.0, 5.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:L · score source
EPSS
  • CVE-2024-38356: 0.53% estimated exploitation activity in the next 30 days; percentile 44.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the noneditableregexp option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor. Patches This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the noneditableregexp option, any content within an attribute is properly verified to match the configured regular expression before being added. Fix To avoid this vulnerability: Upgrade to TinyMCE 7.2.0 or higher. Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x. Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract). References TinyMCE 6.8.4 TinyMCE 7.2.0 For more information If you have any questions or comments about this advisory: Email us at infosec@tiny.cloud Open an issue in the TinyMCE repo

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9hcv-j9pv-qmph

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9hcv-j9pv-qmph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38356

Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option
IDs: CVE-2024-38356, GHSA-9hcv-j9pv-qmph
Record: https://patchnext.com/advisories/cve-2024-38356 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: django-tinymce 4.1.0; tinymce 7.2.0, 6.8.4, 5.11.0; tinymce/tinymce 7.2.0, 6.8.4, 5.11.0; tinymce 7.2.0, 6.8.4, 5.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI django-tinymce: affected <= 4.0.0; fixed in 4.1.0
- NuGet tinymce: affected < 5.11.0; >= 6.0.0, < 6.8.4; >= 7.0.0, < 7.2.0; fixed in 6.8.4, 7.2.0, 5.11.0
- Packagist tinymce/tinymce: affected < 5.11.0; >= 6.0.0, < 6.8.4; >= 7.0.0, < 7.2.0; fixed in 6.8.4, 7.2.0, 5.11.0
- npm tinymce: affected < 5.11.0; >= 6.0.0, < 6.8.4; >= 7.0.0, < 7.2.0; fixed in 6.8.4, 7.2.0, 5.11.0

## Suggested inspection (read-only)
- `python -m pip show django-tinymce`: prints the installed version. Run with the environment that serves production active.
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on django-tinymce, tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9hcv-j9pv-qmph (OSV record GHSA-9hcv-j9pv-qmph lists affected ranges: npm tinymce >=0 =6.0.0 =7.0.0 =0 =6.0.0 =7.0.0 =0 =6.0.0 =7.0.0 =0 <4.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9hcv-j9pv-qmph (GitHub-reviewed advisory GHSA-9hcv-j9pv-qmph lists affected ranges: npm tinymce >=0 =6.0.0 =7.0.0 =0 =6.0.0 =7.0.0 =0 =6.0.0 =7.0.0 =0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…