qdrant input validation failure
CVE-2024-3829GHSA-7m75-x27w-r52r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (qdrant-client 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI qdrant-client
- Affected
- < 1.9.0
- Fixed in
- 1.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7m75-x27w-r52r lists affected ranges: PyPI qdrant-client >=0 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7m75-x27w-r52r lists affected ranges: PyPI qdrant-client >=0 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-3829: 0.91% estimated exploitation activity in the next 30 days; percentile 59.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7m75-x27w-r52r
- Revision 1 · created ·
Published from osv record GHSA-7m75-x27w-r52r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-3829 Advisory: qdrant input validation failure IDs: CVE-2024-3829, GHSA-7m75-x27w-r52r Record: https://patchnext.com/advisories/cve-2024-3829 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: qdrant-client 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI qdrant-client: affected < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - `python -m pip show qdrant-client`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on qdrant-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7m75-x27w-r52r (OSV record GHSA-7m75-x27w-r52r lists affected ranges: PyPI qdrant-client >=0 <1.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7m75-x27w-r52r (GitHub-reviewed advisory GHSA-7m75-x27w-r52r lists affected ranges: PyPI qdrant-client >=0 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…