Apache Tomcat Allocation of Resources Without Limits or Throttling vulnerability
CVE-2024-38286GHSA-7jqf-v358-p8g7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 11.0.0-M1, < 11.0.0-M21>= 10.1.0-M1, < 10.1.25>= 9.0.13, < 9.0.90>= 8.5.35, <= 8.5.100>= 7.0.92, <= 7.0.109
- Fixed in
- 11.0.0-M21, 9.0.90, 10.1.25
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.0-M21>= 10.1.0-M1, < 10.1.25>= 9.0.13, < 9.0.90>= 8.5.35, <= 8.5.100>= 7.0.92, <= 7.0.109
- Fixed in
- 11.0.0-M21, 9.0.90, 10.1.25
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7jqf-v358-p8g7 lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.35 =7.0.92 =11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.35 =7.0.92 <=7.0.109
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2024-38286: 1.69% estimated exploitation activity in the next 30 days; percentile 77.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7jqf-v358-p8g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-38286 Advisory: Apache Tomcat Allocation of Resources Without Limits or Throttling vulnerability IDs: CVE-2024-38286, GHSA-7jqf-v358-p8g7 Record: https://patchnext.com/advisories/cve-2024-38286 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.0-M21, 10.1.25, 9.0.90; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M21, 10.1.25, 9.0.90. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.0-M21; >= 10.1.0-M1, < 10.1.25; >= 9.0.13, < 9.0.90; >= 8.5.35, <= 8.5.100; >= 7.0.92, <= 7.0.109; fixed in 11.0.0-M21, 9.0.90, 10.1.25 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.0-M21; >= 10.1.0-M1, < 10.1.25; >= 9.0.13, < 9.0.90; >= 8.5.35, <= 8.5.100; >= 7.0.92, <= 7.0.109; fixed in 11.0.0-M21, 9.0.90, 10.1.25 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7jqf-v358-p8g7 (GitHub-reviewed advisory GHSA-7jqf-v358-p8g7 lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.35 =7.0.92 =11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.35 =7.0.92 <=7.0.109) Commands are suggestions: review each one before running it.
Loading voting…