Moodle uses the same key for QR login and auto-login
CVE-2024-38277GHSA-r82w-3phg-qvr4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.4.1, 4.3.5, 4.2.8, 4.1.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 4.4.0-beta, < 4.4.1>= 4.3.0-beta, < 4.3.5>= 4.2.0-beta, < 4.2.8< 4.1.11
- Fixed in
- 4.4.1, 4.2.8, 4.1.11, 4.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r82w-3phg-qvr4 lists affected ranges: Packagist moodle/moodle >=4.4.0-beta =4.3.0-beta =4.2.0-beta =0 <4.1.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-38277: 0.24% estimated exploitation activity in the next 30 days; percentile 15.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A unique key should be generated for a user's QR login key and their auto-login key, so the same key cannot be used interchangeably between the two.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r82w-3phg-qvr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-38277 Advisory: Moodle uses the same key for QR login and auto-login IDs: CVE-2024-38277, GHSA-r82w-3phg-qvr4 Record: https://patchnext.com/advisories/cve-2024-38277 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.4.1, 4.3.5, 4.2.8, 4.1.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 4.4.0-beta, < 4.4.1; >= 4.3.0-beta, < 4.3.5; >= 4.2.0-beta, < 4.2.8; < 4.1.11; fixed in 4.4.1, 4.2.8, 4.1.11, 4.3.5 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r82w-3phg-qvr4 (GitHub-reviewed advisory GHSA-r82w-3phg-qvr4 lists affected ranges: Packagist moodle/moodle >=4.4.0-beta =4.3.0-beta =4.2.0-beta =0 <4.1.11) Commands are suggestions: review each one before running it.
Loading voting…