Skip to content

← Actionable
Medium, CVSS 5.1

Moodle stored XSS via calendar's event title when deleting the event

CVE-2024-38274GHSA-p5cg-6rfr-6mx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.4.1, 4.3.5, 4.2.8, 4.1.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.4.0-beta, < 4.4.1>= 4.3.0-beta, < 4.3.5>= 4.2.0-beta, < 4.2.8< 4.1.11
    Fixed in
    4.4.1, 4.2.8, 4.1.11, 4.3.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-38274: 0.38% estimated exploitation activity in the next 30 days; percentile 31.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Insufficient escaping of calendar event titles resulted in a stored XSS risk in the event deletion prompt.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p5cg-6rfr-6mx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38274

Advisory: Moodle stored XSS via calendar's event title when deleting the event
IDs: CVE-2024-38274, GHSA-p5cg-6rfr-6mx8
Record: https://patchnext.com/advisories/cve-2024-38274 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.4.1, 4.3.5, 4.2.8, 4.1.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.4.0-beta, < 4.4.1; >= 4.3.0-beta, < 4.3.5; >= 4.2.0-beta, < 4.2.8; < 4.1.11; fixed in 4.4.1, 4.2.8, 4.1.11, 4.3.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p5cg-6rfr-6mx8 (GitHub-reviewed advisory GHSA-p5cg-6rfr-6mx8 lists affected ranges: Packagist moodle/moodle >=4.4.0-beta =4.3.0-beta =4.2.0-beta =0 <4.1.11)

Commands are suggestions: review each one before running it.

Loading voting…