Skip to content

← Actionable
Critical, CVSS 10.0

DeepJavaLibrary API absolute path traversal

CVE-2024-37902GHSA-w877-jfw7-46rj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ai.djl:api 0.28.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven ai.djl:api

    Affected
    >= 0.1.0, < 0.28.0
    Fixed in
    0.28.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-37902: 0.78% estimated exploitation activity in the next 30 days; percentile 56.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary DeepJavaLibrary(DJL) versions 0.1.0 through 0.27.0 do not prevent absolute path archived artifacts from inserting archived files directly into the system, overwriting system files. This is fixed in DJL 0.28.0 and patched in DJL Large Model Inference containers 0.27.0. Impacted versions: 0.1.0 through 0.27.0 Patches Patched Deep Learning Containers: v1.1-djl-0.27.0-inf-cpu-full v1.4-djl-0.27.0-inf-ds-0.12.6 v1.4-djl-0.27.0-inf-trt-0.8.0 v1.3-djl-0.27.0-inf-neuronx-sdk2.18.1 Patched Library: v0.28.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w877-jfw7-46rj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37902

Advisory: DeepJavaLibrary API absolute path traversal
IDs: CVE-2024-37902, GHSA-w877-jfw7-46rj
Record: https://patchnext.com/advisories/cve-2024-37902 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ai.djl:api 0.28.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven ai.djl:api: affected >= 0.1.0, < 0.28.0; fixed in 0.28.0

## Suggested inspection (read-only)
- Maven ai.djl:api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ai.djl:api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w877-jfw7-46rj (GitHub-reviewed advisory GHSA-w877-jfw7-46rj lists affected ranges: Maven ai.djl:api >=0.1.0 <0.28.0)

Commands are suggestions: review each one before running it.

Loading voting…