XWiki Platform vulnerable to Cross-site Scripting through attachment filename in uploader
CVE-2024-37900GHSA-wf3x-jccf-5g5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-web-war 16.0.0, 15.10.6, 15.5.5, 14.10.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-web-war
- Affected
- >= 4.2-milestone-3, < 14.10.21>= 15.0-rc-1, < 15.5.5>= 15.6-rc-1, < 15.10.6>= 16.0.0-rc-1, < 16.0.0
- Fixed in
- 14.10.21, 15.10.6, 15.5.5, 16.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf3x-jccf-5g5g lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-war >=4.2-milestone-3 =15.0-rc-1 =15.6-rc-1 =16.0.0-rc-1 <16.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2024-37900: 15.80% estimated exploitation activity in the next 30 days; percentile 96.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When uploading an attachment with a malicious filename, malicious JavaScript code could be executed. This requires a social engineering attack to get the victim into uploading a file with a malicious name. The malicious code is solely executed during the upload and affects only the user uploading the attachment. While this allows performing actions in the name of that user, it seems unlikely that a user wouldn't notice the malicious filename while uploading the attachment. In order to reproduce, as any user, create a file named "<img src=1 onerror=alert(1).jpg. Then go to any page where you have edit rights and upload the file in the attachments tab. If alerts appear and display "1", then the instance is vulnerable. Patches This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Workarounds We're not aware of any workaround except upgrading. References https://jira.xwiki.org/browse/XWIKI-19611 https://jira.xwiki.org/browse/XWIKI-21769…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wf3x-jccf-5g5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37900 Advisory: XWiki Platform vulnerable to Cross-site Scripting through attachment filename in uploader IDs: CVE-2024-37900, GHSA-wf3x-jccf-5g5g Record: https://patchnext.com/advisories/cve-2024-37900 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-web-war 16.0.0, 15.10.6, 15.5.5, 14.10.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-web-war: affected >= 4.2-milestone-3, < 14.10.21; >= 15.0-rc-1, < 15.5.5; >= 15.6-rc-1, < 15.10.6; >= 16.0.0-rc-1, < 16.0.0; fixed in 14.10.21, 15.10.6, 15.5.5, 16.0.0 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-web-war: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-web-war. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wf3x-jccf-5g5g (GitHub-reviewed advisory GHSA-wf3x-jccf-5g5g lists affected ranges: Maven org.xwiki.platform:xwiki-platform-web-war >=4.2-milestone-3 =15.0-rc-1 =15.6-rc-1 =16.0.0-rc-1 <16.0.0) Commands are suggestions: review each one before running it.
Loading voting…