Lobe Chat API Key Leak
CVE-2024-37895GHSA-p36r-qxgx-jq2v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 0.162.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lobehub/chat
- Affected
- < 0.162.25
- Fixed in
- 0.162.25
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p36r-qxgx-jq2v lists affected ranges: npm @lobehub/chat >=0 <0.162.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p36r-qxgx-jq2v lists affected ranges: npm @lobehub/chat >=0 <0.162.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-37895: 0.55% estimated exploitation activity in the next 30 days; percentile 45.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If an attacker can successfully authenticate through SSO/Access Code, they can obtain the real backend API Key by modifying the base URL to their own attack URL on the frontend and setting up a server-side request. Details The attack process is described above. PoC Frontend: 1. Pass basic authentication (SSO/Access Code). 2. Set the Base URL to a private attack address. 3. Configure the request method to be a server-side request. 4. At the self-set attack address, retrieve the API Key information from the request headers. Backend: 1. The LobeChat version allows setting the Base URL. 2. There is no outbound traffic whitelist. Impact All community version LobeChat users using SSO/Access Code authentication, tested on version 0.162.13.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p36r-qxgx-jq2v
- Revision 1 · created ·
Published from osv record GHSA-p36r-qxgx-jq2v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37895 Advisory: Lobe Chat API Key Leak IDs: CVE-2024-37895, GHSA-p36r-qxgx-jq2v Record: https://patchnext.com/advisories/cve-2024-37895 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 0.162.25. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lobehub/chat: affected < 0.162.25; fixed in 0.162.25 ## Suggested inspection (read-only) - `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lobehub/chat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p36r-qxgx-jq2v (OSV record GHSA-p36r-qxgx-jq2v lists affected ranges: npm @lobehub/chat >=0 <0.162.25 (fixed)) - Verified: https://github.com/advisories/GHSA-p36r-qxgx-jq2v (GitHub-reviewed advisory GHSA-p36r-qxgx-jq2v lists affected ranges: npm @lobehub/chat >=0 <0.162.25) Commands are suggestions: review each one before running it.
Loading voting…