Skip to content

← Actionable
Medium, CVSS 4.4amended

urllib3's Proxy-Authorization request header isn't stripped during cross-origin redirects

CVE-2024-37891GHSA-34jh-p97f-mpxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (urllib3 2.2.2, 1.26.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI urllib3

    Affected
    < 1.26.19>= 2.0.0, < 2.2.2
    Fixed in
    2.2.2, 1.26.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-37891: 1.14% estimated exploitation activity in the next 30 days; percentile 66.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When using urllib3's proxy support with ProxyManager, the Proxy-Authorization header is only sent to the configured proxy, as expected. However, when sending HTTP requests without using urllib3's proxy support, it's possible to accidentally configure the Proxy-Authorization header even though it won't have any effect as the request is not using a forwarding proxy or a tunneling proxy. In those cases, urllib3 doesn't treat the Proxy-Authorization HTTP header as one carrying authentication material and thus doesn't strip the header on cross-origin redirects. Because this is a highly unlikely scenario, we believe the severity of this vulnerability is low for almost all users. Out of an abundance of caution urllib3 will automatically strip the Proxy-Authorization header during cross-origin redirects to avoid the small chance that users are doing this on accident. Users should use urllib3's proxy support or disable automatic redirects to achieve safe processing of the Proxy-Authorization…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-34jh-p97f-mpxf

  2. Revision 1 · created ·

    Published from osv record GHSA-34jh-p97f-mpxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37891

Advisory: urllib3's Proxy-Authorization request header isn't stripped during cross-origin redirects
IDs: CVE-2024-37891, GHSA-34jh-p97f-mpxf
Record: https://patchnext.com/advisories/cve-2024-37891 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: urllib3 2.2.2, 1.26.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI urllib3: affected < 1.26.19; >= 2.0.0, < 2.2.2; fixed in 2.2.2, 1.26.19

## Suggested inspection (read-only)
- `python -m pip show urllib3`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on urllib3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-34jh-p97f-mpxf (OSV record GHSA-34jh-p97f-mpxf lists affected ranges: PyPI urllib3 >=0 =2.0.0 <2.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-34jh-p97f-mpxf (GitHub-reviewed advisory GHSA-34jh-p97f-mpxf lists affected ranges: PyPI urllib3 >=0 =2.0.0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…