Permission model improperly processes UNC paths
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 22.4.1, 20.15.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 20.0.0, < 20.15.1>= 22.0.0, < 22.4.1
- Fixed in
- 20.15.1, 22.4.1
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2024-37372 to 2024-07-08.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 146 lists CVE-2024-37372 affecting node >=20.0.0 =22.0.0 <22.4.1
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-37372: 0.49% estimated exploitation activity in the next 30 days; percentile 42.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Permission Model assumes that any path starting with two backslashes \\ has a four-character prefix that can be ignored, which is not always true. This subtle bug leads to vulnerable edge cases. This vulnerability affects Windows users of the Node.js Permission Model in version v20.x and v22.x
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:146
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:146
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37372 Advisory: Permission model improperly processes UNC paths IDs: CVE-2024-37372 Record: https://patchnext.com/advisories/cve-2024-37372 (revision 2, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 22.4.1, 20.15.1. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 20.0.0, < 20.15.1; >= 22.0.0, < 22.4.1; fixed in 20.15.1, 22.4.1 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2024-37372 to 2024-07-08.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/146.json (Node.js security working group core entry 146 lists CVE-2024-37372 affecting node >=20.0.0 =22.0.0 <22.4.1) Commands are suggestions: review each one before running it.
Loading voting…