Skip to content

← Actionable
Medium, CVSS 5.3

CrateDB has a Client initialized Session-Renegotiation DoS

CVE-2024-37309GHSA-x268-qpg6-w9g2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.crate:crate 5.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-37309: 0.70% estimated exploitation activity in the next 30 days; percentile 53.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Client-Initiated TLS Renegotiation Denial of Service (DoS) Vulnerability at Port 4200 Details A high-risk vulnerability has been identified where the TLS endpoint (port 4200) permits client-initiated renegotiation. In this scenario, an attacker can exploit this feature to repeatedly request renegotiation of security parameters during an ongoing TLS session. This flaw could lead to excessive consumption of CPU resources, resulting in potential server overload and service disruption. The vulnerability was confirmed using an openssl client where the command 'R' initiates renegotiation, followed by the server confirming with 'RENEGOTIATING'. PoC 1. Connect to the TLS server on port 4200 using an openssl client. 2. Initiate a TLS session. 3. Send the renegotiation command ('R') multiple times. 4. Observe the server response to confirm renegotiation. Impact This vulnerability allows an attacker to perform a denial of service attack by exhausting server CPU resources through…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x268-qpg6-w9g2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37309

Advisory: CrateDB has a Client initialized Session-Renegotiation DoS
IDs: CVE-2024-37309, GHSA-x268-qpg6-w9g2
Record: https://patchnext.com/advisories/cve-2024-37309 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.crate:crate 5.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.crate:crate: affected < 5.7.2; fixed in 5.7.2

## Suggested inspection (read-only)
- Maven io.crate:crate: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.crate:crate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x268-qpg6-w9g2 (GitHub-reviewed advisory GHSA-x268-qpg6-w9g2 lists affected ranges: Maven io.crate:crate >=0 <5.7.2)

Commands are suggestions: review each one before running it.

Loading voting…