Skip to content

← Actionable
High, CVSS 7.9

Cilium leaks sensitive information in cilium-bugtool

CVE-2024-37307GHSA-wh78-7948-358j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.15.6, 1.14.12, 1.13.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/cilium/cilium

    Affected
    >= 1.13.0, < 1.13.17>= 1.14.0, < 1.14.12>= 1.15.0, < 1.15.6
    Fixed in
    1.13.17, 1.15.6, 1.14.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.9 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2024-37307: 0.18% estimated exploitation activity in the next 30 days; percentile 7.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The output of cilium-bugtool can contain sensitive data when the tool is run (with the --envoy-dump flag set) against Cilium deployments with the Envoy proxy enabled. Users of the following features are affected: - TLS inspection - Ingress with TLS termination - Gateway API with TLS termination - Kafka network policies with API key filtering The sensitive data includes: - The CA certificate, certificate chain, and private key used by Cilium HTTP Network Policies, and when using Ingress/Gateway API - The API keys used in Kafka-related network policy cilium-bugtool is a debugging tool that is typically invoked manually and does not run during the normal operation of a Cilium cluster. Patches This issue affects: - Cilium v1.13 between v1.13.0 and v1.13.16 inclusive - Cilium v1.14 between v1.14.0 and v1.14.11 inclusive - Cilium v1.15 between v1.15.0 and v1.15.5 inclusive This issue has been patched in: - Cilium v1.15.6 - Cilium v1.14.12 - Cilium v1.13.17 Workarounds There is no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wh78-7948-358j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37307

Advisory: Cilium leaks sensitive information in cilium-bugtool
IDs: CVE-2024-37307, GHSA-wh78-7948-358j
Record: https://patchnext.com/advisories/cve-2024-37307 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.15.6, 1.14.12, 1.13.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.13.0, < 1.13.17; >= 1.14.0, < 1.14.12; >= 1.15.0, < 1.15.6; fixed in 1.13.17, 1.15.6, 1.14.12

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wh78-7948-358j (GitHub-reviewed advisory GHSA-wh78-7948-358j lists affected ranges: Go github.com/cilium/cilium >=1.13.0 =1.14.0 =1.15.0 <1.15.6)

Commands are suggestions: review each one before running it.

Loading voting…