Skip to content

← Actionable
High, CVSS 8.1amended

Globus identity_provider restriction ignored when used with allow_all in JupyterHub 5.0

CVE-2024-37300GHSA-gprj-3p75-f996

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthenticator 16.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2024-37300: 0.40% estimated exploitation activity in the next 30 days; percentile 34.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact JupyterHub < 5.0, when used with GlobusOAuthenticator, could be configured to allow all users from a particular institution only. The configuration for this would look like: This worked fine prior to JupyterHub 5.0, because allowall did not take precedence over identityprovider. Since JupyterHub 5.0, allowall does take precedence over identityprovider. On a hub with the same config, now all users will be allowed to login, regardless of identityprovider. identityprovider will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. Patches OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. Workarounds Do not upgrade to JupyterHub 5.0 when using GlobusOAuthenticator in the prior configuration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gprj-3p75-f996

  2. Revision 1 · created ·

    Published from osv record GHSA-gprj-3p75-f996

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37300

Advisory: Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0
IDs: CVE-2024-37300, GHSA-gprj-3p75-f996
Record: https://patchnext.com/advisories/cve-2024-37300 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauthenticator 16.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI oauthenticator: affected < 16.3.1; fixed in 16.3.1

## Suggested inspection (read-only)
- `python -m pip show oauthenticator`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauthenticator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gprj-3p75-f996 (OSV record GHSA-gprj-3p75-f996 lists affected ranges: PyPI oauthenticator >=0 <16.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-gprj-3p75-f996 (GitHub-reviewed advisory GHSA-gprj-3p75-f996 lists affected ranges: PyPI oauthenticator >=0 <16.3.1)

Commands are suggestions: review each one before running it.

Loading voting…